We are updating admin.servebolt.com
Incident Report for Servebolt
Resolved
This incident has been resolved.
Posted about 1 year ago. May 29, 2018 - 13:06 CEST
Monitoring
We are rolling out new updates for the admin panel and the control panel may be unavailable for short periods of time for the coming hour.
Posted about 1 year ago. May 29, 2018 - 10:34 CEST
This incident affected: admin.servebolt.com.